summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAdam T. Carpenter <atc@53hor.net>2023-11-08 22:50:42 -0500
committerAdam T. Carpenter <atc@53hor.net>2023-11-08 22:50:42 -0500
commit595556a089057993604485070f0f12cc2952e01d (patch)
treeee43428e704f0fad1de8ce9de6a941b47680c824 /Cargo.toml
parent17bf761fe95b621e66f1b023c6b5f229e488daa3 (diff)
downloadcarpentertutoring-595556a089057993604485070f0f12cc2952e01d.tar.xz
carpentertutoring-595556a089057993604485070f0f12cc2952e01d.zip
feat: rust serverdev
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..d3bef0c
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "carpentertutoring"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+askama = { version = "0.12.1", features = ["with-axum"] }
+axum = "0.6.20"
+tokio = { version = "1.33.0", features = ["full"] }
+tower = "0.4.13"
+tower-http = { version = "0.4.4", features = ["fs"] }
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.17", features = ["env-filter"] }