summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAdam T. Carpenter <atc@53hor.net>2024-09-07 21:18:54 -0400
committerAdam T. Carpenter <atc@53hor.net>2024-09-07 21:18:54 -0400
commitae00627e7c99fd21ce4ad8ec0692445f00a349b2 (patch)
tree9af9c980db9075fbc0e520443201d684a0a03832 /Cargo.toml
parent4ae354f108acaef8c78b778124d4638904bd7c69 (diff)
downloadcarpentertutoring-ae00627e7c99fd21ce4ad8ec0692445f00a349b2.tar.xz
carpentertutoring-ae00627e7c99fd21ce4ad8ec0692445f00a349b2.zip
feat: basic markdown post to html page loading
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..a496dbf
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "carpentertutoring"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+askama = { version = "0.12", features = ["markdown", "with-axum"], default-features = false }
+askama_axum = "0.4.0"
+axum = "0.7.5"
+tokio = { version = "1.40.0", features = ["full"] }