summaryrefslogtreecommitdiff
path: root/dichroism/Cargo.toml
diff options
context:
space:
mode:
authorAdam T. Carpenter <atc@53hor.net>2022-05-02 22:32:52 -0400
committerAdam T. Carpenter <atc@53hor.net>2022-05-02 22:32:52 -0400
commitc7d885e4b8189e4539c1f259a44ec37c6cd027b2 (patch)
treedc2b0486c123404854ae44fc49ac57f0eca18734 /dichroism/Cargo.toml
parentf243a3b7341012227d6e8342a65f9c5d7784256f (diff)
downloadtheglassyladies-c7d885e4b8189e4539c1f259a44ec37c6cd027b2.tar.xz
theglassyladies-c7d885e4b8189e4539c1f259a44ec37c6cd027b2.zip
feat: reset button read config start db pool and launch axum serverssr
Diffstat (limited to 'dichroism/Cargo.toml')
-rw-r--r--dichroism/Cargo.toml31
1 files changed, 15 insertions, 16 deletions
diff --git a/dichroism/Cargo.toml b/dichroism/Cargo.toml
index 4f18bb5..98656fd 100644
--- a/dichroism/Cargo.toml
+++ b/dichroism/Cargo.toml
@@ -1,26 +1,25 @@
[package]
name = "dichroism"
-version = "0.1.0"
+version = "1.0.0"
authors = ["Adam T. Carpenter <atc@53hor.net>"]
-edition = "2018"
+edition = "2021"
[dependencies]
-actix-cors = "0.5"
-actix-multipart = "0.3"
-actix-web = "3"
-async-std = "1"
+r2d2 = "0.8"
+r2d2_sqlite = "0.20"
+serde_rusqlite = "0.30"
+anyhow = "1.0"
+axum = "0.5"
base64 = "0.13"
-diesel = { version = "1", default-features = false, features = [ "sqlite", "r2d2" ] }
-env_logger = "0.8"
+env_logger = "0.9"
futures = "0.3"
-image = "0.23"
-kamadak-exif = "0.5.2"
-listenfd = "0.3"
+image = "0.24"
+kamadak-exif = "0.5"
log = "0.4"
-mime = "0.3"
-once_cell = "1"
-regex = "1"
+tokio = { version = "1.0", features = ["full"] }
+tower-http = { version = "0.3.0", features = ["fs"] }
+# mime = "0.3"
+rusqlite = "0.27"
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
-toml = "0.5"
-uuid = { version = "0.8", features = ["v3"] }
+uuid = { version = "1.0", features = ["v3"] } \ No newline at end of file