summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAdam T. Carpenter <atc@53hor.net>2024-11-14 21:49:47 -0500
committerAdam T. Carpenter <atc@53hor.net>2024-11-14 21:49:47 -0500
commit4aa45ef3e7798ee18bea8b49af75e383afce02a1 (patch)
tree7a1353753d9300929b43a561ff2f1aae59b6434f /Cargo.toml
parent014e34fa4a8cd4e3cdb3573a7748696c68873523 (diff)
parentfc0e8296178ca779a270d91b681777f50b3b626d (diff)
downloadcarpentertutoring-4aa45ef3e7798ee18bea8b49af75e383afce02a1.tar.xz
carpentertutoring-4aa45ef3e7798ee18bea8b49af75e383afce02a1.zip
Merge branch 'release'HEADmaster
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..30fd4f8
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "carpentertutoring"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+askama = { version = "0.12", features = ["markdown", "with-axum"], default-features = false }
+askama_axum = "0.4.0"
+axum = "0.7.5"
+chrono = { version = "0.4.38", default-features = false, features = ["now"] }
+tokio = { version = "1.40.0", features = ["full"] }
+tower = "0.5.0"
+tower-http = { version = "0.5.2", features = ["fs", "trace", "normalize-path"] }
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }