summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..30fd4f8
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "carpentertutoring"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+askama = { version = "0.12", features = ["markdown", "with-axum"], default-features = false }
+askama_axum = "0.4.0"
+axum = "0.7.5"
+chrono = { version = "0.4.38", default-features = false, features = ["now"] }
+tokio = { version = "1.40.0", features = ["full"] }
+tower = "0.5.0"
+tower-http = { version = "0.5.2", features = ["fs", "trace", "normalize-path"] }
+tracing = "0.1.40"
+tracing-subscriber = { version = "0.3.18", features = ["env-filter"] }