summaryrefslogtreecommitdiff
path: root/dichroism/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'dichroism/Cargo.toml')
-rw-r--r--dichroism/Cargo.toml15
1 files changed, 12 insertions, 3 deletions
diff --git a/dichroism/Cargo.toml b/dichroism/Cargo.toml
index d921225..0e19889 100644
--- a/dichroism/Cargo.toml
+++ b/dichroism/Cargo.toml
@@ -4,15 +4,24 @@ version = "0.1.0"
authors = ["Adam T. Carpenter <atc@53hor.net>"]
edition = "2018"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+name = "dichroism"
+path = "src/lib.rs"
+
+[[bin]]
+name = "dichroismd"
+path = "src/bin/dichroismd.rs"
[dependencies]
actix-web = "3"
+async-std = "1"
base64 = "0.13"
-diesel = { version = "1.4", features = [ "sqlite" ] }
+diesel = { version = "1.4", features = [ "sqlite", "r2d2" ] }
env_logger = "0.7"
image = "0.23"
-lazy_static = "1"
listenfd = "0.3"
log = "0.4"
+once_cell = "1"
regex = "1"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"