summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAdam T. Carpenter <atc@53hor.net>2021-04-02 18:23:45 -0400
committerAdam T. Carpenter <atc@53hor.net>2021-04-02 18:23:45 -0400
commitb1c45640a72300433800c8370657335616f8c541 (patch)
treead7df1bfa6f59390ad227183364b308ab2137ed0 /Cargo.toml
parent7633bf5855ae5359d0fe280970e5c5c210c536b3 (diff)
downloadtwinh-b1c45640a72300433800c8370657335616f8c541.tar.xz
twinh-b1c45640a72300433800c8370657335616f8c541.zip
replaced mongo with sled, added some basic functional google oauth2 code
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4fc3f0c..72dff12 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,13 +7,14 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+bincode = "1.3"
env_logger = "0.8"
handlebars = "3.5"
hyper = { version = "0.14", default-features = false, features = ["full"] }
+hyper-rustls = "0.22"
log = "0.4"
-mongodb = "1.2"
once_cell = "1.7"
-serde = "1.0"
-serde_json = "1.0"
+serde = { version = "1.0", features = ["derive"]}
serde_urlencoded = "0.7"
+sled = "0.34"
tokio = { version = "1.2", default-features = false, features = ["full"] }