summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAdam T. Carpenter <atc@53hor.net>2021-04-28 19:58:27 -0400
committerAdam T. Carpenter <atc@53hor.net>2021-04-28 19:58:27 -0400
commitf206de5d49eda1900552a4b19f01c8c6985b7903 (patch)
tree86f0b681e01eeda4a8d5f03a85c988866538b981 /Cargo.toml
parentd83fe68ed51016bbb87d83aa512ef8b9d3f0780e (diff)
downloadtwinh-f206de5d49eda1900552a4b19f01c8c6985b7903.tar.xz
twinh-f206de5d49eda1900552a4b19f01c8c6985b7903.zip
finally committed to structopt arg parsingenhancement/2
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 13b4535..b625320 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,17 +2,19 @@
name = "twinh"
version = "0.1.0"
authors = ["Adam T. Carpenter <atc@53hor.net>"]
+description = "Twin H-Power: A classic car parts catalog and cross-reference tool"
edition = "2018"
[dependencies]
bincode = "1"
env_logger = "0.8"
handlebars = "3"
-hyper = { version = "0.14", default-features = false, features = ["full"] }
+hyper = { version = "0.14", default-features = false, features = ["server", "client", "http1", "http2"] }
hyper-rustls = "0.22"
log = "0.4"
-once_cell = "1"
+lazy_static = "1.4"
serde = { version = "1", features = ["derive"]}
serde_urlencoded = "0.7"
sled = "0.34"
-tokio = { version = "1", default-features = false, features = ["full"] }
+structopt = { version = "0.3", default-features = false }
+tokio = { version = "1", default-features = false, features = ["rt-multi-thread", "macros", "signal"] }