summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 4 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7deeff7..b376c93 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,18 +3,14 @@ name = "twinh"
version = "0.1.0"
authors = ["Adam T. Carpenter <atc@53hor.net>"]
description = "Twin H-Power: A dead simple classic car parts catalog and cross-reference tool"
-edition = "2018"
+edition = "2021"
[dependencies]
-bincode = "1"
env_logger = { version = "0.8", default-features = false }
handlebars = "3"
-hyper = { version = "0.14", default-features = false, features = ["server", "client", "http1", "http2"] }
-hyper-rustls = "0.22"
log = "0.4"
-lazy_static = "1.4"
+rusqlite = "0.26.3"
serde = { version = "1", features = ["derive"]}
serde_urlencoded = "0.7"
-sled = "0.34"
-structopt = { version = "0.3", default-features = false }
-tokio = { version = "1", default-features = false, features = ["rt-multi-thread", "macros", "signal"] }
+totp-lite = "1"
+anyhow = "1"